VxLAN Static Replication

Voor de configuratie van VxLAN zijn er verschillende methodes van implementatie. Eén van deze implementaties is Static Replication, onderstaande topologie zal gebruikt worden:

topology

Om te kunnen starten met de configuratie van VxLAN Static Replication is onderstaande underlay configuratie benodigd. We maken alleen gebruik van OSPF, er is geen multicast benodigd in de underlay.

LEAF configuratie (underlay)

feature ospf
!
interface loopback0
  ! LEAF 3: ip address 3.3.3.3/32
  ! LEAF 4: ip address 4.4.4.4/32
  ! LEAF 5: ip address 5.5.5.5/32
  ip router ospf 10 area 0.0.0.0
!
interface loopback1
  ! LEAF 3: ip address 33.33.33.33/32
  ! LEAF 4: ip address 44.44.44.44/32
  ! LEAF 5: ip address 55.55.55.55/32
  ip router ospf 1 area 0.0.0.0
!
interface Ethernet1/1
  no switchport
  ! LEAF 3: ip address 13.13.13.3/24
  ! LEAF 4: ip address 14.14.14.4/24
  ! LEAF 5: ip address 15.15.15.5/24
  ip ospf network point-to-point
  ip router ospf 10 area 0.0.0.0
  no shutdown
!
interface Ethernet1/2
  no switchport
  ! LEAF 3: ip address 23.23.23.3/24
  ! LEAF 4: ip address 24.24.24.4/24
  ! LEAF 5: ip address 25.25.25.5/24
  ip ospf network point-to-point
  ip router ospf 10 area 0.0.0.0
  no shutdown
!
router ospf 10

SPINE configuratie (underlay)

feature ospf
!
interface loopback0
  ! SPINE 1: ip address 1.1.1.1/32
  ! SPINE 2: ip address 2.2.2.2/32
  ip router ospf 10 area 0.0.0.0
!
interface Ethernet1/3
  no switchport
  ! SPINE 1: ip address 13.13.13.1/24
  ! SPINE 2: ip address 23.23.23.2/24
  ip ospf network point-to-point
  ip router ospf 10 area 0.0.0.0
  no shutdown
!
interface Ethernet1/4
  no switchport
  ! SPINE 1: ip address 14.14.14.1/24
  ! SPINE 2: ip address 24.24.24.2/24
  ip ospf network point-to-point
  ip router ospf 10 area 0.0.0.0
  no shutdown
!
interface Ethernet1/5
  no switchport
  ! SPINE 1: ip address 15.15.15.1/24
  ! SPINE 2: ip address 25.25.25.2/24
  ip ospf network point-to-point
  ip router ospf 10 area 0.0.0.0
  no shutdown
!
router ospf 10

Het is vanuit de vendor aanbevolen op de loopback voor de underlay en de loopback voor VxLAN van elkaar te scheiden. Loopback 0 is voor OSPF, Loopback 1 zal gebruikt worden voor de VxLAN configuratie.

Configuratie verificatie

Laten wij controleren dat wij de routes zien en dat wij vanuit het Loopback 1 interface kunnen pingen naar het Loopback 1 adres van een andere LEAF.

NXOS-3# show ip route 4.4.4.4/32
IP Route Table for VRF "default"
'' denotes best ucast next-hop '*' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%' in via output denotes VRF 
4.4.4.4/32, ubest/mbest: 2/0
    *via 13.13.13.1, Eth1/1, [110/81], 00:00:42, ospf-10, intra
    *via 23.23.23.2, Eth1/2, [110/81], 00:00:42, ospf-10, intra

NXOS-3# ping 4.4.4.4 count 1 source-interface loopback 1
PING 4.4.4.4 (4.4.4.4): 56 data bytes
64 bytes from 4.4.4.4: icmp_seq=0 ttl=253 time=6.193 ms

Nu dat OSPF correct werkt kan de configuratie van VxLAN geplaatst worden.

LEAF configuratie (VxLAN)

feature nv overlay
feature nv-segment-vlan-based
!
vlan 66
  vn-segment 6600
vlan 67
  vn-segment 6700 
!
interface nve1
  no shutdown
  source-interface loopback1
  member vni 6600
    ingress-replication protocol static
      ! LEAF 3: peer-ip 44.44.44.44
      ! LEAF 3: peer-ip 55.55.55.55
      ! LEAF 4: peer-ip 33.33.33.33
      ! LEAF 4: peer-ip 55.55.55.55
      ! LEAF 5: peer-ip 33.33.33.33
      ! LEAF 5: peer-ip 44.44.44.44
  member vni 6700
    ingress-replication protocol static
      ! LEAF 3: peer-ip 44.44.44.44
      ! LEAF 3: peer-ip 55.55.55.55
      ! LEAF 4: peer-ip 33.33.33.33
      ! LEAF 4: peer-ip 55.55.55.55
      ! LEAF 5: peer-ip 33.33.33.33
      ! LEAF 5: peer-ip 44.44.44.44 

Voor het activeren van de VxLAN functionaliteit activeren wij feature nv overlay. Voor het kunnen koppelen van een VLAN aan een VxLAN (VxLAN Gateway) hebben we de feature nv-segment-vlan-based nodig.

We maken hier gebruik van VLAN 66 en koppelen dit aan VxLAN 6600, al het verkeer wordt door middel van static replication verstuurd naar de VTEP’s. Ditzelfde doen we ook voor VLAN 67. Het nadeel van deze oplossing is dat het beheer en het consistent houden van de peer-ip’s bij een grotere schaal lastiger wordt.

VxLAN verificatie

Er zijn verschillende commando’s om de componenten van VxLAN te controleren. Laten we beginnen met de controle of wij data-plane of control-plane geconfigureerd hebben, dit zou data-plane moeten zijn:

NXOS-3# show nve interface
Interface: nve1, State: Up, encapsulation: VXLAN
 VPC Capability: VPC-VIP-Only [not-notified]
 Local Router MAC: 5000.0003.0007
 Host Learning Mode: Data-Plane
 Source-Interface: loopback1 (primary: 33.33.33.33, secondary: 0.0.0.0)

We kunnen controleren dat de NVE interface online is gekomen:

NXOS-3# show interface nve 1
nve1 is up
admin state is up,  Hardware: NVE
  MTU 9216 bytes
  Encapsulation VXLAN
  Auto-mdix is turned off
  RX
    ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes
  TX
    ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes

Vervolgens kunnen we de NVE relaties controleren:

NXOS-3# show nve peer
Interface Peer-IP          State LearnType Uptime   Router-Mac       
--------- ---------------  ----- --------- -------- -----------------
nve1      44.44.44.44      Up    DP        00:19:00 n/a              
nve1      55.55.55.55      Up    DP        00:07:04 n/a       

Evenals de koppeling van VNI, VLAN en multicast groepen:

NXOS-3# show nve vni
Codes: CP - Control Plane        DP - Data Plane          
       UC - Unconfigured         SA - Suppress ARP        
       SU - Suppress Unknown Unicast 
       Xconn - Crossconnect      
       MS-IR - Multisite Ingress Replication
Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags

nve1      6600     UnicastStatic     Up    DP   L2 [66]                 
nve1      6700     UnicastStatic     Up    DP   L2 [67]    

En nu de laatste verificatie kunnen wij van VPC-10 pingen naar VPC-12:

VPCS-10> show
 NAME   IP/MASK              GATEWAY                             
 VPCS1  192.168.67.10/24     0.0.0.0

VPCS-12> show
 NAME   IP/MASK              GATEWAY                              
 VPCS1  192.168.67.12/24     0.0.0.0

VPCS-10> ping 192.168.67.12
 84 bytes from 192.168.67.12 icmp_seq=1 ttl=64 time=14.780 ms

VPCS-12> ping 192.168.67.10
 84 bytes from 192.168.67.10 icmp_seq=1 ttl=64 time=115.446 ms